Feeld is currently supported only on phones running Android 8 or higher, or iOS 13 or higher.

Newer versions of the app will not be available for download in devices with older versions of Android or iOS.

We appreciate that this may inconvenience some of our members. However, older operating systems are no longer compatible with the technology stack we’re working with. Enforcing a minimum supported operating system version allows us to provide more stability and improvements to the app.

Before we make any changes to minimum supported versions, we will notify affected members in due course to prompt them to update. Rest assured that, if you’re running an OS that can’t support Feeld, your data will remain safe, and you will be able to log in using the same account once you upgrade to a newer version of Android or iOS.

If you have any questions, please send us an email to [email protected].

Did this answer your question?